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Agenda 
 
The purpose of this session is to acquaint people with Import capabilities in Sage 300 CRE.  In this 
session, we will focus on imports into 
 
 General Ledger: 
 Budgets 
 Transactions 
 Cash Management, 
 Cleared Checks 
 Job Cost: 
 Estimates 
 Direct Cost Entries 
 Commitments 
 Accounts Payable 
 Invoices 

Note that there also are import capabilities in 
 
 Payroll 
 Time entries 
 Accounts Receivable 
 Invoices 
 Purchasing & Inventory 
 Inventory Items 
 Requisitions/Orders/other items 

 
We’ll take a look at a few things such as: 
 

 Understanding the formats and use of the various Import Templates. 
 What the import files look like. 
 Where the import files might come from – i.e.  3rd party programs, Excel, Access 
 How to import these files into Sage 300 CRE.  

 
For information about how to import into any module you can go to: 
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Any Module>Help>Index>Import you can find Import file layouts, fields, field definitions, optional 
vs required fields and file examples. 
 
 
Importing into General Ledger - General Ledger has the ability to import budgets and/or 
transactions. 
 
Budgets 
Many people do their budget work in a spreadsheet because they provide a familiar and flexible 
environment for number crunching.  Spreadsheets give users the ability to very effectively 
manipulate data, summarizing columns, link cells, and format printouts.  Spreadsheets are 
designed explicitly for this purpose. 
 
Recognizing this, Sage 300 CRE has tools that allow you to import budgets created in 
spreadsheets.  There is also a tool for importing transactions that works in the same fashion.    
Importing budgets into Sage 300 CRE can save you hours of redundant data entry. 
 
 
Budget records can be imported from a comma-delimited text file into General Ledger using the 
Import Budgets command from the Tools menu, GL:Tools > Import Budgets. The imported budget 
records are verified and, if no errors are found, they are written to the budget records in the 
General Ledger Master file. 
 
Records rejected during the import process are copied from the import source file and written to 
a rejected records text file, with the same format as the import file. The rejected records file then 
can be edited using any text (i.e. Notepad) that will not convert the file from the comma-
delimited text format to a different format. 
 
The import file remains intact during processing and is not deleted when the task completes. As a 
result, if you are reprocessing a group of previously rejected records, be sure to enter the name 
of the rejected records file as the source import file name, not the name of the original import 
file. The system will warn you that a file was previously imported.  
 
Budget Types 
 
Prior to creating budgets, you must define your budget types using Common 
Tasks>File>Company Settings>Custom Descriptions.  Sage 300 CRE supports up to ten different 
budget types.   Budget types are used to define different kinds of budgets.  For example, you 
might create a Preliminary Budget type for those budgets awaiting approval, a Final Budget type 
for approved budgets and a Revised Budget type for modified budgets. 
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Setting up the Spreadsheet 
 

1. Insert a blank worksheet in your budget workbook. 
2. Set up the columns according to the import record format.  You can label the sheet 

“Export Budget”. 
3. Copy the account column from the budget sheet into the account column in the export 

sheet. 
4. Delete any blank rows. 
5. Manually enter the Record ID (GLB), Budget Year and Budget Type in the first three 

columns. 
6. Use the VLookup function to pull information from the budget sheet. 

a. Income accounts must be entered in Sage 300 CRE as credits.  If the spreadsheet 
shows income as positive values, then change the Vlookup formula to return a 
negative.  Vacancy loss amounts would be entered as positive numbers 

b. Use ‘absolute reference’ when copying formulas. 
7. Copy the first row over to the last column.   Use ‘absolute references’ by toggling F4 in the 

formula. 
8. Change the ‘column index’ in each cell as needed. 
9. Copy the cells down.   Remember to remove the minus from the VLookup formula for 

expense accounts. 
a. Format the amount columns with no commas.  The file will be saved as a CSV 

(Comma Separated Value) file and if numbers have commas in them they will be 
interpreted as another field in the import 

b. Save the Excel file as a regular workbook. 
c. Do a ‘Save as’ and save it again as a CSV file.   You will receive a message telling 

you that saving the file as CSV does not support multiple workbooks. Just say OK. 
10. Then exit the CSV file. 

#,"Previously Imported","by Carmen Martin","on  2-26-2014","at 11:10 am" 
 
;,,1,2,3,4,5,6,7,8,9,0,1,2,3,Acc" "GLB,2013,1,4000,700000,,,,,,,,,,,,,1" "GLB,2013,1,5000,,,,,,,,,,,,,,1" 
"GLB,2013,1,5010,300000,,,,,,,,,,,,,1" "GLB,2013,1,5020,100000,,,,,,,,,,,,,1" 
"GLB,2013,1,5030,50000,,,,,,,,,,,,,1"  
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Understanding Excel’s VLookup Function 
 
Searches for a value in the leftmost column of a table, and then returns a value in the same row 
from a column you specify in the table. 
 
In plain English: 
Lookup Value – What am I comparing? Table_array – Where am I looking for it? Col_index_num – 
Which column should I return? 
Range_lookup – Nearest or Exact Match (always use False here). 
 
Steps for Importing Budgets 
 

1. From the Tools menu, select Import Budgets. 
2. Enter the import source file name in Import file. The file name can have any extension (up to three 

characters).  If no extension is entered, the default extension (.TXT) is appended automatically. 
3. Enter the Rejected records file name. The file name can have any extension (up to three 

characters).  If no extension is entered, the default extension (.TXT) is appended automatically. 
4. Select how to handle duplicate budget records.  
5. Make any necessary printer and page adjustments and click [Start] to begin processing. 
6. Review the Import Budgets journal for errors. If errors exist, correct them in the rejected record 

file. 
7. If you encountered errors in step 6, correct the errors and repeat steps 1 through 6 to import the 

previously rejected entries. Be sure to use the corrected rejected records file as the import file 
when importing those entries, not the original import source file. 

 
Importing Transactions into General Ledger 
 

1. Transaction records can be imported from a comma-delimited text file into General Ledger using 
the Import Transactions command from the Tools menu (GL:Tools  > Import  Transactions).  The 
imported transactions are verified and, if no errors are found, they are written to the New General 
Ledger Transaction file. 

2. Records rejected during the import process are copied from the import source file to a rejected 
records text file, which has the same format as the import file. The rejected records file then can 
be edited using any text editor that does not convert the file from the comma-delimited text 
format to a different format. 

3. The import file remains intact during processing and is not deleted when the task completes. As a 
result, if you are reprocessing a group of previously rejected records, be sure to enter the name of 
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the rejected records file as the import file name, not the name of the original import file. The 
system does not warn you that a file was previously imported, so reentering the original import 
file name will create duplicate entries. 

4. After you have reviewed the imported transactions, and corrected and reprocessed any errors, 
the entries are ready to be posted to General Ledger. To update the General Ledger Master file, 
use the Post Entries command from the Tasks menu (GL:Tasks > Post Entries).  

 
Steps for Importing Transactions 
 

1. From the Tools menu, select Import Transactions. 
2. If General Ledger is set up to manually assign batches, a batch selection window opens. You may 

create a new batch or select an existing batch. 
3. Enter the import source file name in Import file. The file name can have any extension (up to three 

characters).  If no extension is entered, the default extension (.TXT) is appended automatically. 
4. Enter the Rejected records file name. The file name can have any extension (up to three 

characters).  If no extension is entered, the default extension (.TXT) is appended automatically. 
5. Make any necessary printer and page adjustments and click [Start] to begin processing. 
6. Review the Import Transactions journal for totals of transactions imported and errors 

encountered. If errors exist, correct them in the rejected records file. 
Note: Typically, if there is a rejected record in the import file the debits and credits won’t tie out 
and the system won’t import anything.  You can usually just make corrections in the original file 
and then import it again. 

7. If you encountered errors in step 6, correct the errors and repeat steps 1 through 6 to import the 
previously rejected entries. Be sure to use the corrected rejected records file as the import file 
when importing those entries, not the original import source file. 

8. If the import is free of errors, post the imported entries to the General Ledger Master file.  

 
Importing Cleared Checks in Cash Management 
You can use Import Cleared Checks (Tools menu) to import cleared check information from an 
import text file into Cash Management.  The system verifies the information in the text file, and if 
the import is successful, you can see the effect on the check entry in Edit Register (Tasks menu) 
and in the bank account (Setup > Bank Accounts). 
 
Edit Register Changes: 
Reconciliation status changes to Cleared. 
 Cleared amount field fills with the amount that you imported. 
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 Cleared date field fills with the cleared date on the import text file. Bank Account 
Changes: 

 Bank balance decreases by the total imported amount (General tab). 
 Open checks total decreases by the total imported amount (Totals tab). 
 Open total balance increases by the total imported amount. 
 If Import Cleared Checks detects an error in the text file, the information does not import. 

Import /formats and templates 
 
Import   Cleared   Checks   requires   only   four   fields   to   import   cleared   check information: 

 Bank account number 
 Check number 
 Amount 
 Check cleared date 

You can import cleared checks using either a comma delimited file or a fixed length file. You may 
find it easier to work with the comma delimited format. 
 
Sample file example -- comma-delimited template 
If check number 1550 for $79.00 cleared Terrapin Bank (Bank ID = TERPBK), account number 
4522397*, on June 26, 2003, the text file is written as follows: 
 
TERPBK,1550,79.00,06262003  
 
Edit the fixed-format template 
Required template fields: 

 Account number 
 Check number 
 Amount 
 Cleared date 

If the text file you received from your bank has additional fields that are unnecessary for a 
successful import, you must edit the template so that it recognizes and ignores the additional 
fields. 

1. Copy and paste the Cm_fixed.tpl file from X:Program  Files\  Sage 300 CRE\Accounting\template  
(if  X is  the  drive  that  contains  your Sage 300 CRE directory) to another location. 

2. Rename the file. The file name must begin with CM_ and it must have a .tpl extension. (For 
example, CM_USBank.tpl.) 
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3. Compare the fields on the template to the fields on your bank’s text file. Adjust the size of the 
blanks in your template to correspond with the position and size of all the fields on the bank’s text 
file that are not required for import. 

4. Save the template; copy it back to the original template folder. 
5. Test your import file template. 

You can now use this template, without further editing, to import cleared check information as 
long as your bank’s text file format does not change.  
 
Steps to Import Cleared Checks 
 

1. Select Import Cleared Checks (Tools menu). 
2. Enter the import source file name in the Import file field. The file name can have any extension (up 

to three characters). If no extension is entered, the default extension (TXT) is appended 
automatically. Click [. . .] to locate the file. 

3. Type or browse to the file name in which you want to store rejected information in the Rejected 
records file field. The file name can have any extension (up to three characters).  If no extension is 
entered, the default extension (TXT) is appended automatically. Click [. . .] to browse to the file. 

4. Select the import format to use for importing the cleared checks. If you have only one import 
format stored in your Template folder (Sage 300 CRE directory), Import Cleared Checks 
automatically defaults to that template. Otherwise, select the format from the list. 

5. Make any necessary printer and page adjustments and click [Start] to begin processing. 
6. Review the Import Cleared Checks journal for warnings or errors. 
7. If the journal contains errors, correct them in the rejected information file and repeat steps 1-5 to 

import the corrected entries. Be sure to select the rejected information file, not the original 
import source file, as the import file when you import the corrected entries.  

 
Importing Estimates into Job Cost 

1. You can import estimates from an ASCII comma delimited text file by using the JC:Tools>Import 
Estimates command.  This is accessible through Tools > Import >Estimates or through the Job 
Costing and Contract Administration Workflow Center. As long as the comma delimited 
text file conforms to the record layout accepted by Job Cost, you can use any software to 
create the import file.  

2. Sage Estimating automatically generates this import file in the accepted format. You can 
also prepare estimates in an Excel spreadsheet. 

3. You do not need to set up a new job before importing the estimate.  If the job ID is 
specified in the import file, the Import Estimates command will create the new job as it 
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imports the estimate. You can later add the   remaining setup information in the Job Setup 
window or in Job Central. 

4. Other third party software can generate import files. 

The estimate import template contains five types of import records: 
 Job header - This record contains static information related to the job or jobs in the 

import file. 
 Cost code - This is an optional record. It is used to enter production units and description. 
 Category - This record is required whether or not you are using categories. It is used to 

enter estimated units and cost. 
 Extra - This is an optional record. Use it for jobs where extras are included. 
 Comment—A line that begins with a semi-colon is a comment line and is ignored in the 

translation. 

Note: You can print out the files layouts from the Help menu.  Find out more by going to 
Help>Help Topics in Job Cost.  Click on the index tab and type in “import”. 
 
Sample Excel estimate file: 
 
;Precision Estimating Interface File 
*,98-013,"QUAIL FISHING LODGE            ","                                   
","MALHEUR ","OR    ",                  ,"DONNER  UND BLITZEN  ASSOC               
","57 ANTELOPE ","FRENCH GLENN   ","OR  ",        ,   8000,SQFT 
P, 1-041,"Project Coordination         ",,05301998 
C, 1-041,"Labor                       ",L  ,05301998,       .0000,,    22000.00 
P, 1-065,"Permits - General            ",,05301998 
C, 1-065,"Other                      ",O ,05301998,       .0000,,      675.00  
 
You can print these template from Job Cost by going to Help>Help Topics. Click on the Index tab 
and type Import.  
 
Then choose from one of the import formats: 
 Import Estimate Job Header Layout 
 Import Estimate Cost Code Layout 
 Import Estimate Category Layout 
The rows shown in the templates relate to columns of information that would exist, for instance, 
in an Excel file. 
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Steps to Import an Estimate 
 

1. From the Tools menu, select Import > Estimate. 
2. Enter the import file name. You can click [Customer Info] to verify customer information 

from the import text file. 
3. Enter a name for the file that will hold any rejected records. If you do not include a suffix, 

".jce" is added.  
4. Select the Cost Code check box if you want to allow the import process to create new 

records for cost codes whose IDs are in the import file but not on the standard cost code 
list. This option is available only if you use categories. 

5. Select the Import Estimate as Approved Change if you want to create an approved 
estimate change transaction. The Approved Estimate Change and Total Estimate fields are 
updated. 

6. Change the print options as necessary; then click [Start]. 
7. Review the Estimate Import Report for a list of estimates imported and errors 

encountered. If the rejected file has errors, correct them and use the corrected reject file 
as an import file. 

8. If the import is free of errors, post the imported entries to the Job Cost Master. 
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Importing Direct Costs into Job Cost 
 
 You can also import direct costs from an ASCII comma delimited text file by using the 

Import Direct Cost command.   This is accessible through Tools > Import >Direct Cost.  As 
long as the comma delimited text file conforms to the record layout accepted by Job Cost, 
you can use any software to create the import file. 

 Most cost transactions post into Job Cost from normal processing from Accounts Payable 
and Payroll. 

 Direct cost is any cost on a job that don’t come from anywhere else in the system. For 
example, if you happen to use outside payroll services, you could use Import Direct Cost 
to get those cost onto the job. 

Note:  As with the estimates, you can print out the files layouts from the Help menu.  Find out 
more by going to Help>Help Topics in Job Cost.  Click on the index tab and type in “import”.  
 
Scenario:  A construction company is both the GC on a job and subs out labor to a subsidiary 
company.  They have two Sage 300 CRE company folders, one for the GC and another for the Sub.  
They wanted an efficient way to bring the Sub cost into the GL folder. 
 
Solution: They use the same job and cost code numbering in both folders.  When they want to 
send cost accumulated in the sub up to the GC they run a report which creates a direct cost 
import file which they then import into the GC Company. 
 
Importing Commitments into Job Cost 
 Commitments in Job Cost refer to Subcontracts and/or Purchase Orders. 
 You can import commitments and commitment change orders from an ASCII comma 

delimited text file by using the Import Commitments command.   As long as the comma 
delimited text file conforms to the record layout accepted by Job Cost, you can use any 
software to create the import file.  Sage 300 CRE Buyout, and the Purchasing and 
Inventory applications automatically generate this import file in the accepted format.  

Importing Invoices into Accounts Payable 
 

1. Accounts Payable has the ability to import invoices. If you maintain a spreadsheet of invoice 
information in Excel or if you can receive an electronic invoice file from a vendor, then you can 
import them into Accounts Payable saving you a great deal of data entry time. 
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2. Invoice records can be imported from a comma-delimited text file into Accounts Payable using the 
Import Invoices command from the Tools menu. The imported records are verified and, if no 
errors are found, they are written to the New.API file. 

3. The Import Template can be based on either a “Variable Format” or a “Fixed Format”. The 
columns needed in Variable Format import can vary depending on your company’s AP Settings. 
With the Fixed Format, you use a template that accounts for all possible invoice fields regardless 
of your AP Setting.  I prefer to use the Fixed Format because it will work even if your AP Settings 
are changed at some point. 

4. You do need to make sure that the pertinent coding information is available in the file to be 
imported. 

5. Each invoice that gets imported must have an invoice line and one or more distribution line(s), and 
a tax line if you are tracking taxes.  Just like entering an invoice manually, you first enter the 
invoice and then enter the invoice distribution information 

Note: You can find out more about the Import Invoice Format by going to Accounts 
Payable>Help.  Click the Index Tab and type “import”.  This will tell you about the process of 
importing invoices as well as the file format required to do so.  
 
Scenario:   A property management company manages hundreds of properties. They use an 
outside payroll company to process their payroll which is paid from a central disbursement 
account.   They then need to have each of the properties process reimbursements via Accounts 
Payable.   This normally entails manually entering invoices for each property each week. 
 
Solution: Using Microsoft Access in conjunction with Import Invoices in Accounts Payable allows 
them to accomplish this in a few minutes.  Access takes the payroll information supplied by the 
payroll company and applies a series of steps to create the comma-delimited text file that the 
import process in Accounts Payable looks for. 


